Using network folders instead of local ones

Hi,

is there a way to use mounted drives or symlinks onto network drives instead of only local drives?
My intention is to store my data onto my server and to use more than just one pc to work with paperwork (just me, but working with pc or notebook)

Greetz, Christoph

Hello,

It should have worked in Paperwork 2.0. It’s actually a bug.
Benjunmun fixed it, but it will only be available in Paperwork 2.1.

Anyway, assuming you are using Linux, you can use more traditional ways to mount network shares: Windows/Samba shares, NFS. It will work transparently for Paperwork.

Best regards,

Hi,

do I have to make special setup for using samba-shares with paperwork? When I try to connect / to open e.g. to the share “Dokumente” I just get the message “Inhalt von Dokumente kann nicht gelesen werden - kein Ordner” (like “can’t read Dokumente - no folder”)

I always working with this folder from all other applications and all system without any problems - also my famil use it …

Greetz

Assuming you mounted them using the command mount (or through the fstab file), it should work.
Can you submit a bug report using the built-in feature please (application menu (the three-bars menu aka “hamburger menu”) → “report bug”) ? It will send me Paperwork’s logs, which will make it easier for me to understand what’s going on.

Hi, I reported this problem as wished with the buildin error reporting tool.
Here is also the screenshot of this case …

Greetz

PS: I just noticed, that this problem also is there during import - I can’t import from a samba-share

Hello,

From what I understand of your screenshot, you’re trying to use your network share through GVFS (in other words using Gnome tools and graphical user interface). As mentioned before, it doesn’t work in Paperwork 2.0.2. It’s a known bug that will be fixed in Paperwork 2.1.

Again, if you want to use Paperwork with network shares on Linux, your only option is to use the command line tools like mount -t cifs and/or fstab

Best regards,

Hi,

my drives are prepared in fstab as -t cifs, but with noauto.
I mount them with a cron-job which runs about 120s after plasma-login. I mount them to /mnt/freenas/, and I link them with symlinks into the places I need them.

Unfortunately I can’t see themnt-folder in root, also paperwork shows just the dokument-folder just like a document (see pic at the mousepointer)
Paperwork2 - SMB-Fehler2

I try to set my drive like this:

s1. etting
2. working-dir
3. “andere Orte”
4. choose omv - SMB-CIFS
5. choose drive I wish
6. before descriped error appears

Greetz

Hello Christoph,

What do you mean by “I can’t see themnt-folder in root”?

To access it, simply click on the drive icon on the left of the “home” button at the top of the window, here you normally have /mnt… Do you mean you do not see it here?

Hi,

I made a screeshot for you where you can see - left window is paperwork and the seen folder, right is filemanager krusader and all of my root-folders …

Oh, yes. Probably because of Flatpak limitations, containerization, etc, I don’t remember how they call it.
I don’t know how to tell an app bundled with Flatpak it can access this directory. Jerome, do you have some details?

I think it could work if you mount it under your home directory, but I admit it is not optimal.

Oh right, I forgot about that, sorry. By default Paperwork, when running in Flatpak, can only access your home directory.

You can use the following command to give it access to extra directories:

flatpak override work.openpaper.Paperwork --filesystem=<path_here>

(source)

Hi,

at least I made a new share direct from my home into the Dokument-Folder on the NAS just for Paperwork, because the overide-option does also not work for me …

Now I have the data there I want, and I can use them from everywhere in my lan

Greetz, and many thanks

Christoph

PS: Hm, there is just a problem - if I try to change the documents date at a fresh imported doc, I can’t do it. Everything else seems to work as well.
And doc which I had inside of pw before I transferred everything into the new share I can also change the date successfully

Hi,
it is a little curious - I can’t use a linked dir for storing the workingdata, but if I export a safed document e.g. as pdf, I can use every dir onto my pc, also these ones I mounted with fstab into /mnt and linked into the place I need them.

Greetz,
Christoph