Use of Windows 10 and Windows Subsystem for Linux 2 - Notes

All,

Some notes for the Paperwork community and anyone who may come here looking for such information.

I have a Windows 10 Pro desktop (i7, 12Gb ram, multiple drives). I have a Brother HL-L2395DW printer/copier. I have WSL2, latest version, Ubuntu is the installed Linux distro. I have VcXsrv installed for X apps.

Currently this install works incredibly well and as a 20+ year IT guy who used *nix extensively in my work it makes me happy. I decided recently to catchup my Paperwork papers after a few years of neglect. In that time I shifted from a desktop Linux distro to Windows 10 (for reasons) and looked to see if Paperwork can work in this WSL2 environment. I’m happy to say that it CAN.

My Paperwork papers are on an attached USB drive, which is then synced with Dropbox.

The 1.3.1 version of Paperwork that comes with the Ubuntu distro can “see” the Brother device with the Brother-provided Linux drivers installed. While it’s a titch slow (e.g., starting a scan results in a 5-10 second lag), the scans work perfectly. All aspects of the program work but one, that I can see. Opening Settings and selecting Scan for Scanner Calibration results in:

Error while scanning: Error while scanning: libinsane-quark: Libinsane opt[mode]->set_value() error: 0x40000003, Invalid value (4)

I’ve not worried about this as the scans I get a quite fine.

One might ask why I’m not using Paperwork v2 for Windows. I tried it, but there is a problem which prevents a scan from completing - the process halts after the scan, but before the tags/date are added. There is no way I can see to go forward. I submitted a bug report.

One might ask by why I’m not using the flatpak version of the latest Linux release. I tried it, but though all dependencies and v2 of Paperwork install without error, all attempts to run Paperwork 2 fail with an error. Rather than attempt to resolve this (since it is likely due to use of WSL2, which, of course, is not a complete Linux distro install with systemd, etc.), and since I have to do additional steps to get the scanner visible to Paperwork run with flatpak as well (saned, etc.), and since I have a working v 1.3.1, I decided to let it go and get on with my archiving.

If the Windows bug I reported is resolved, I may shift to its use.

Hope this may be of use to someone.

Hello,

Can you submit a scan test report with IronScanner https://openpaper.work/fr/scanner_db/#contribute please ?
It would provide more details regarding your scanner.

Best regards,

Jerome,

All three ironscanner options fail.

Windows: installer runs, the after some minutes aborts. I see the following in the AppData\Local\Temp folder for two attempts to run it:

“C:\Users\guyst\AppData\Local\Temp\uncaught_exception_screenshots_vors727f.png”
“C:\Users\guyst\AppData\Local\Temp\uncaught_exception_screenshots_f5wz__1i.png”

These are both 0 byte files and appeared at approximately the same time as running the installer.

There are two error logs, links to them below.

ironscanner_210128T174150.657.log is for the Linux executable version of ironscanner which fails with:

Failed to load ‘openpaperwork_core.config.fake’

ironscanner_install_log_error.log is the error log on my attempt to use the instructions to build from source, which also failed with

subprojects/libinsane-gobject/doc/meson.build:4:10: ERROR: Program(s) [‘gtkdoc-scan’] not found or not executable

Thus I cannot give you the report you requested. Happy to trouble-shoot these as you direct. I’m no programmer (well, a little perl, shells scripting, and javascript) but I’ve no experience with Python and how it works to help there, but will do what I can.

Links:

Jerome,

I have a working dev version! Looking further into tweaking the scans which are not, quite, as I said above, perfect They are slightly enlarged and thus some text may be cut off the page. Anyway, I found the only other form post where a user reported that same error I reported above in using the Settings>Configure option in my Ubuntu v1.3.1 install. One of your responses mentioned running the dev version and provided the page detailing how to do that.

I have this afternoon followed those steps successfully and have a running dev version. This version successfully completes the Scanner calibration that version 1.3.1 does not complete.

So, unless you advise otherwise I will continue its use.

It does have one issue, however – it does not list my labels! It shows that docs have labels and they are correct. But any attempt to modify a label reveals that the list of about 24 labels I have in version 1.3.1 does not appear in this dev version. Is it possible to get them? Before I have to manually recreate them.

Regards.

Jerome - following up ironscanner. Since the dev build was successful, I reattempted the ironscanner build. It also was successful. Alas running the ironscanner application as a local user or as root fails in multiple places. After entering information on the first screen (name, email) and selecting my scanner and options, clicking on the Next control opens an error dialog. Closing that and continuing a scan, initiates a scan, but also fills the area where the scan would be displayed with a lot of error output and no scanned page gets shown. Continuing since the program does not abort I get to the sending phase and it, too, fails.

So, I still cannot provide you the requested information.

Jerome - Nevermind on the label issue. I noticed what may have been some errant .var/ and .local/ files perhaps created in my efforts with the various versions of Paperwork. I deleted both .var/ and .local/ paperwork files and restarted the dev version. It rebuilt the index and I now see the expected labels.

So, other than the ironscanner issues, I’m good.

Overall that’s good news :slight_smile:

Regarding WSL2, I think I should have clarified things immediately: In my view, WSL2 is an emulation layer, with all the problems emulation layers may cause. So I’m not going to support Paperwork on top of WSL2 (or IronScanner for that matter). You can run Paperwork on top of WSL2 if you want, but you are on your own. Also, I do not want scan reports from IronScanner running on top of WSL2 in the scanner database.

Regarding IronScanner, well, sorry, my bad. I made some changes in Paperwork, and since IronScanner and Paperwork share some code, it broke IronScanner and I didn’t notice. It’s fixed now.
Can you download again and retry the Windows version of IronScanner please ? I’m always interrested in new scan reports :slight_smile:

Jerome - no worries on WSL2 support. As a 30 year IT guy (who retired last July) I understand completely. Support is a nightmare!! I started down that path for several reasons and I’m quite pleased that the dev version appears to be fully working (been scanning for several hours – it’s a tad slow at times, but all appears to be working as designed).

I’ll download and submit the scanner report using the Windows ironscanner.

And as I said in an earlier post, I’m happy to use the Windows port of paperwork if it will work. My bug report (which I should note does not appear in the bug report list - OpenPaper.work - Paperwork - Bug Report Jan. 26, 2021, 9:32 p.m.) was about the Windows version. It worked for importing documents, but did not complete a document when using the scanner. It appears to scan the files, that is, it connects to the scanner and initiates a scan. But the next step of adding the date and label does not happen - it just stops at that point. I waited 15 minutes and it didn’t go farther than that and I tried several times. As I’m even less familiar with Windows programming than *nix programming, I’m not likely much use in installing the dev version on Windows.

ironscanner downloaded and run: OpenPaper.work - Scan report 484 - Brother HL-L2395DW

Thanks for a great app. You’ll get a PayPal donation from me later today.

1 Like

which I should note does not appear in the bug report list

I’m not sure what bug report list you have in mind (Gitlab ?). Anyway that’s by design: Automated bug reports are much easier to submit than Gitlab tickets … too easy actually. Even if they are automatically censored, my fear is that people could still include private information by mistake in them. So they are kept private by default. The URL you posted contains a secret key to make sure nobody can guess the URL. People are then free to share this URL once they are confident there are no personal information in the bug report (in a Gitlab ticket or here for instance :slight_smile: ). On my side, I have access to an admin page that lists all the bug reports (and tells me which one I haven’t read yet), but there are no public lists with those bug reports.

I did have a look at your bug report. Unfortunately, the logs are a bit weird. It’s like something is missing. Can you submit another one please ?

Regarding the dev version, it’s quite easy to install on Windows too. Here is the installer: https://download.openpaper.work/windows/installer/paperwork_develop_installer.exe (but I would be really surprised if it fixes your problem ; and beware that the label guessing feature is being upgraded and is fairly slow at the moment).

And presto-chango, it now works! Please delete that problematic bug report.

So you’ll know :wink: I spent the last nine years of my IT career as the Team Lead for the University of Wisconsin Madison’s Digital Document Management Service. We used Hyland’s Perceptive Content (formerly Lexmark ImageNow). I am VERY familiar with digital document management LOL. I was also the Team developer in charge of customer bulk document acquisition processes (which is where my skills with javascript come from, since Perceptive Content’s API was based on ECMA javascript).

Your Paperwork is a terrific app for personal use. I was very, very happy when I first found it several years ago back when, if I remember rightly, there was no Windows version. I spend several weeks digitizing all my paper – sort of doing in my personal life what I did daily in my professional life. Unfortunately, for reasons, I had to give up my local Linux desktop and move to Windows 10, which meant I lost the ability to continue using Paperwork. WSL2 gave me the possibility to see if Paperwork might be viable, and as I said in this forum post, it very much is. And now, of course, you have a Windows version as well.

I am very happy to again have your app for my personal use! And happy to be able to provide to you some support for doing so.

1 Like