[Resolved] No scanner found

Hi
After reading in a magazine about PaperWork, I have installed it on my Dell laptop running ElementryOS.
I installed PaperWork as a FlatPack by pressing the Install button from Flathub here.
I can start Paperwork, and import scans from folders, but when I try to do a scan from PaperWork, I get this:
“No scanner found.
You use Paperwork from Flatpak container. Paperwork needs Saned to access your Scanners. Go eneble Saned on the host system, you can use the following commands:
sudo apt install sane-utils
sudo sh -c “echo 127.0.0.1 >> /etc/sane.d/saned.conf”
sudo systemctl enable saned.socket
sudo systemctl start saned.socket”
I have tried to run the commands, but with no result.
My scanner/printer is a Canon MG2400 series, and works well with SimpleScan.
Do anyone have any god ideas as to how i can make PaperWork work?
Best Regards
VikingPenguin

I must check may configuration (tomorrow), but my problem was that scanner were not put in saned user/group. I had to add a udev file, and than it worked perfectly. You may want to check your scanner in dev, and check the permission (user/group). lsusb could help you identifying your device

Hello,

Have you already had a look at the Paperwork/Flatpak FAQ ? As mentioned by @cate , in some cases, there are some permissions to correct.

Hello
Thank you for your fast reply :smile:

cate:
If I run lsusb I find the printer:
Bus 001 Device 006: ID 04a9:176c Canon, Inc.

jflesch.
Trying to read through the FAQ (not being a very technically minded user) I found out that there seems to be a error with something called:
Warning. org.freedesktop.Platform.openh264 is not installed
It looks like a bug is being discussed here but still awaits going into PROD.

Best regards
VikingPenguin

No need to worry about that. h264 is an audio/video codec. Paperwork has no use for it.

Anyway, as said in the FAQ, just try to run the following commands in a terminal:

sudo adduser saned plugdev
sudo adduser saned scanner

You may have to restart your computer for them to take effect.

If it doesn’t work, can you post the result of ls -l /dev/bus/usb/001 here please ?

Once again, thank you for your input.

I tried the 2 commands you send.
The first added sanned to Plugdev
The second said that the user Sanned were already member.

After that I tried PaperWork again, but still the same error.
Also after a restart of the laptop.

The result of ls -l /dev/bus/usb/001

:~$ ls -l /dev/bus/usb/001
totalt 0
crw-rw-r-- 1 root root 189, 0 jan 28 06:47 001
crw-rw-r-- 1 root root 189, 1 jan 28 06:47 002
crw-rw-r-- 1 root root 189, 2 jan 28 06:47 003
crw-rw-r-- 1 root root 189, 3 jan 28 06:47 004
crw-rw-r-- 1 root root 189, 4 jan 28 06:47 005
crw-rw-r–+ 1 root lp 189, 5 jan 28 06:50 006

Hopes this help you helping me :wink:

OK, I think the following command should fix your problem.

sudo adduser saned lp

If it does, I will update the Flatpak FAQ with it.

It did… :joy:

Thank you so much.

Now I can not wait to start using PaperWorks.

Since this is my first post in this forum, shall I somehow set the post to resolved?

Best regards to your all.
VinkingPenguin

1 Like

I have only setup this forum recently (before this forum, the project was using a mailing-list). To be honest … I don’t know :slight_smile:
I’ll have a look later. If the thread can/must be set to resolved, I’ll mark it myself.

I’ve added this command the Flatpak FAQ.

Regarding the resolved status, it seems it’s possible using a Discourse plugin. But I’m too lazy to install it right now :slight_smile:

I am very impressed with the help I have received, so I am now a sneak peek patron :grin:

1 Like